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1 purpose
This manual is designed to help users and field engineers quickly install, configure, and use the
BA (/ BC) 50 series image-type code reader.

2 product description
2.1 List of product models

Table1. List of product models

model resolution

ratio

focal

distance

illuminant communica

tion

Support code system

BC50-K80RP-MRS

1280x800

80mm
Red

polarization

Serial port

+ Ethernet,

support

RS232 /

TCP / IP

and Profinet

communicat

ion

Support for 1D / 2D codes

1D-

Code 128 (GS1-128) Code 93

Code 39

CODABAR

EAN/UPC

Interleaved 2 of 5

2D-

Data Matrix(ECC200) QR

BC50-K130RP-MRS 130mm

BC50-K200RP-MRS 200mm

BC50-K80R-MRS 80mm

Red routineBC50-K130R-MRS 130mm

BC50-K200R-MRS 200mm

BC50-K80B-MRS 80mm

Blue routineBC50-K130B-MRS 130mm

BC50-K200B-MRS 200mm

BC50-K80W-MRS 80mm
White

routine
BC50-K130W-MRS 130mm

BC50-K200W-MRS 200mm

BA50-K80RP-MRS 80mm
Red

polarization

Only 1D code is supported

Code 128 (GS1-128) Code 93

Code 39

CODABAR

EAN/UPC Interleaved 2 of 5

BA50-K130RP-MRS 130mm

BA50-K200RP-MRS 200mm

BA50-K80R-MRS 80mm

Red routineBA50-K130R-MRS 130mm

BA50-K200R-MRS 200 mm
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2.2 main unit
1-Built-in light source

2-Position the LED lights

3-The lens

4-Read the code status light

5-Function key

The 6-PWR power supply

indicator lamp

The 7-COM communication

indicator light

8-OK Read code status indicator

lamp

9-R / T, status light

10-M12-17 P-pin-connecting

cable

11-M12-4D-hole-connecting line

Fig1.BA (/ BC) 50 Location and name of main components

3 lighting system
3.1 Built-in light source
The BA (/ BC) 50 is equipped with a built-in light source for the auxiliary lighting of the code
reader. As shown in FIG. 1, the lighting system is composed of four LED light sources and divided
into upper and lower groups, which can be controlled separately by software commands. The
optional lighting modes are:
(1) Only on the upper light source in strobe mode;
(2) In the strobe mode, only open the lower light source;
(3) Turn on all the light sources in the strobe mode;
(4) Turn on all the light sources in the normal bright mode;
(5) Turn off all light sources.

pay attention to

When lighting, please do not look directly at this LED light source, which may damage

the eyes. In addition, in the use process, it can also be closed through the software.

3.1.1 Locate LED lights

This series uses two red positioning LED lights for auxiliary positioning of the reader, the LED
lights through function keys (see section4) To open or close.
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pay attention to

If this positioning LED lamp is lit, please do not look at the lamp, which may harm the eye. In
addition, it can also be closed through function keys and software.

3.2 The LED status indicator lamp
The following table lists all the functions of the LED status indicators:

Table2The.LED status indicator lamp status

4 function key
To facilitate the configuration, BA (/ BC) 50 also provides function keys. This feature preset three
modes and distinguished by key time:

function Key
length

explain pilot lamp

Position the LED

lights on / off

1-3 s Assist for adjusting the installation
position of the code reader

COM lights up

automatic exposure 4-6 s Automatically configure the exposure
parameters for the image settings, Group 1

OK lights up

Code self-learning 7-9 s Automatically configure the decoding
parameters for the image settings, Group 1

R / T, and the light is
on

Table3. Description of the function button

pay attention to

1. Function key trigger is only used in the offline state (software not open).

grade name function explain

6 PWR
Power supply status indicator

lamp
After the power is on, the light is
always on green

7 C OM
Communication status indicator

light

A green strobe indicates a network
communication
A yellow strobe indicates an RS232
communication

8 O K
Read the code status indicator

lamp

Green indicates a successful code
reading
Red indicates a failed code read

9 R/ T
The Ready / Triger indicator

light
Red color indicates the Read y
The green color indicates the T rigger
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2. The key duration is defined as the time interval between pressing and releasing the function
key. If the button exceeds 9s, the device will be ed again.

3. When selecting the mode, the selection can be confirmed by the indicator status of the long
button, such asTable 3As shown. The different indicator lights are in turn on and orange
during the long press selection mode. For example, to enter automatic exposure mode, press
the function button until the OK light turns orange.

4. After successfully entering the target mode, the corresponding indicator light of this mode
switches from orange always bright to orange flashing, indicating that the mode is running.

5. If the mode ends successfully, the indicator light corresponding to the mode flashes green.
Click the function key again (double click to turn off the location LED light), you can save
the current configuration and write it to the upper computer software configuration program,
and the indicator light returns to the normal operating mode.

6. After entering the target mode, you can terminate or exit by clicking the key again. If the
selected mode is still running, terminate it and return to the normal flow. Cannot cancel if the
selected mode runs successfully.
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5 install
5.1 Install the reader
1. Select the appropriate location to install the reader within the recommended read distance

range.
2. For bracket mounting, attach the reader to the holder for detailsFig 2-Fig 4。
3. In order to facilitate the subsequent adjustment of the position and Angle of the code reader,

please do not tighten the screw for the time being.
4. According to the images acquired by the reader (see section11), Further adjust the read

distance of the reader.
5. Hold the screws to ensure the reader (and mounting bracket) remains in the desired position.

Fig2. BA (/ BC) 50 Installation bracket size (mm)

Fig3. BA (/ BC) 50 size (mm)
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Fig4. Schematic diagram of the stent installation

5.2 Connect the HW interface
The BA (/ BC) 50 series simultaneously supports a variety of communication interfaces: RS232
serial port, Ethernet TCP / IP, industrial Ethernet Pr ofinet, and hardware PNP / NPN interface.

5.2.1 The PIN pin and wiring definition for the hardware I /

O

Fig5. PIN of power & I / O cable, foot definition

PIN Line color description

supply electricity

17 brown Vdc, input power cathode +

15 Brown white Vdc, input power cathode +

13 blue Power supply negative electrode GND / RS232
GND

16 Blue and

white

Power supply negative electrode GND / RS232
GND

RS232 I/O
5 pink RS232_TX

6 yellow RS232_RX

n.a.
7 green obligate

8 white obligate

PNP/NPN
import

10 purple DIN _ 1 _ A: Port A for the PNP / NPN 1st route
input

12 hoary DIN _ 1 _ B: Port B for PNP / NNP 1st route input

11 skewbald DIN _ 2 _ A: Port A for PNP / NPN Route 2 input

9 red DIN _ 2 _ B: Port B for PNP / NPN Route 2 input

14 black and ISO _ GND photocoupling ground



Tianjin Eco Automation Co., Ltd 0 ELCO-USG-01 10

white

PNP/NPN
output

3 black DOUT _ 1 _ A: Port A for the PNP / NPN 1st
route output

1 orange DOUT _ 1 _ B: Port B for PNP / NPN # 1st output

2 Orange white DOUT _ 2 _ A: Port A for PNP / NPN 2nd way
output

4 gray DOUT _ 2 _ B: Port B for PNP / NPN 2nd way
output

Table4. Interface definition of the power & I / O cables

Fig6. Ethernet cable PIN pin definition

PIN Line color description

1 Orange white TX_P

2 Green white RX_P

3 orange TX_N

4 green RX_N

Table5. Interface definition of the Ethernet cable

5.2.2 RS232 Serial port
If the signal is triggered or output by serial port of RS232, the field engineer may refer to itTable 6,
Direct connect the RS232 signal to the connecting line M12-17P.

P IN Line color connecting pin

5 pink colour RS232_TX

6 yellow RS232_RX

13/16 Blue / blue

white

RS232_GND

Table6. RS232 input and output

5.2.3 Ethernet TCP / IP and industrial Ethernet Profinet
For the Ethernet TCP / IP and Profinet, connect the M12-4D-hole-connecting cable using the
optional accessory M12-4D-pin-RJ 45 network port.
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5.2.4 Hardware PNP / NPN trigger
BA (/ BC) 50 also supports two PNP / NPN trigger inputs. Users and site engineers can select any
one-way or two simultaneous inputs as required. Each of the inputs can arbitrarily choose one of
the trigger modes.

pay attention to

The voltage of the trigger signal shall be in the range of 12 V-24V, and its current shall exceed 5
mA.

5.2.4.1 PNP detonate by contact

When triggered by PNP, the connection of the input end can be referred toTable 7AndTable 8：

PIN Line color connecting pin

10 purple PNP trigger signal

14 black and white Common with the negative power source of the trigger signal

Table7. PNP Trigger-1st way input DIN _ 1

PI N Line color connecting pin

11 skewbald PNP trigger signal

14 black and white Common with the negative power source of the trigger signal

Table8. PNP Trigger-2nd way input DIN _ 2

5.2.4.2 NPN detonate by contact

When triggered by NPN, the connection of the input end can be referred toTable 9AndTable 10：

PIN Line color connecting pin

10 purple NPN trigger signal

12 hoary Positive positive source

14 black and white Common with the negative power source of the trigger signal

Table9. NPN trigger-1st way input DIN _ 1
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PIN Line color connecting pin

11 skewbald NPN trigger signal

9 red Positive positive source

14 black and white Common with the negative power source of the trigger signal

Table10. NPN trigger-2nd way input DIN _ 2

pay attention to

If the external NPN trigger signal has its own power supply (i. e., not sharing the same power
source with the code reader), it is necessary to ensure that the negative power source of the
NPN, the power source of the code reader (13-blue / 16-blue and white) and the ISO optical
coupling ground (PIN 14-black and white) of the code reader coexist.

5.2.5 Hardware PNP / NPN output
BA (/ BC) 50 simultaneously supports two PNP / NPN output. Users and field engineers can select
1 output or use 2 output simultaneously. Each of the output can arbitrarily choose one of the
output modes.

5.2.5.1 PNP output

If the PNP output is required, the connection of the output end can be referred toTable 11AndTable
12：

PIN Line color connecting pin

3 black Positive positive source

1 orange PNP output signal

Table11. PNP output-1st way output DOUT _ 1

PIN Line color connecting pin

2 Orange white Positive positive source

4 gray PNP output signal

Table12. PNP output-2nd way output DOUT _ 2

5.2.5.2 NPN output

If the NPN output is required, the connection of the output end can be referred toTable
13AndTable 14：
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PIN Line color connecting pin

3 black NPN output signal

1 orange Connected to the negative electrode of the code reader power source

Table13. NPN output-1st way output DOUT _ 1

PIN Line color connecting pin

2 Orange white NPN output signal

4 gray Connected to the negative electrode of the code reader power source

Table14. NPN output-2nd way output DOUT _ 2

5.3 computer configuration
The host running the ELCO configurator shall meet the following requirements:

 Operating system: Windows 7 or higher

 System type: 64-bit

 Processor: at least 2.00 GHz

 Memory: at least 1GB RAM

 Hard drive: 1 GB (32-bit); 2GB (64-bit)

 Screen resolution: Please use the system-recommended resolution

 Communication: 100 Base-T Ethernet
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6 performance parameter
Table15. BA (/ BC) 50 performance parameters

model The BA (/ BC) 50 series

surface
size 50 mm ⅹ 48 mm ⅹ 25mm

material quality aluminium
source service voltage 12 - 24Vdc

I/O

TCP/IP
Profinet

RS232 The RS232 level

PNP/ NPN
Enter * 2 VIN: 12 - 24Vdc, IIN≥ 5mA.

output *2 VOUT: 5 - 24Vdc, IOUT140 mA (average current).

sensor Resolution: CMOS 1280x800 Imaging speed: 60 frames / s

Read the
specifications

Support code system
Data Matrix (ECC 200), QR (Model 2).

Code 128 (GS1-128), Code 93, Code 39, CODABAR,
EAN/UPC, Interleaved 2 of 5

minimum resolution 5 mil

Read the distance SeeTable 16，Table 17，Table 18

environment

operating ambient temperature 0 ~ 50 ℃

Storage environment
temperature

-20 ~ 70 ℃

relative humidity <= 90% (no condensate)

IP grade IP65

Table16. BC50-K80R-MRS read distance (V at 80mm focal length: 61x38mm)

code system
exposure

time
gain

Barcode

resolution
Read the distance

The

proximal

field of view

(Horizontal x

vertical)

Far end field

of view

(Horizontal x

vertical)

Code39 500 us 4

6 mil 30 mm - 100 mm 27 x 18 mm 81 x 52 mm

8 mil 30 mm - 120 mm 27 x 18 mm 95 x 62 mm

12 mil 40 mm - 155 mm 34 x 22 mm 122 x 79 mm

20 mil 70 mm - 200 mm 56 x 36 mm 155 x 100 mm

Code128 500 us 4

6 mil 40 mm - 110 mm 34 x 22 mm 88 x 57 mm

8 mil 40 mm - 130 mm 34 x 22 mm 102 x 67 mm

12 mil 50 mm - 145 mm 41 x 27 mm 114 x 75 mm

20 mil 80 mm - 215 mm 61 x 38 mm 166 x 105 mm

Interleaved

2 of 5 500 us 4

8 mil 35 mm - 125 mm 30 x 20 mm 99 x 64 mm

12 mil 35 mm - 155 mm 30 x 20 mm 122 x 79 mm

20 mil 50 mm - 205 mm 41 x 27 mm 162 x 100 mm

Data Matrix

(ECC200)
500 us 4

5 mil 50 mm - 75 mm 41 x 27 mm 59 x 38 mm

7.5 mil 45 mm - 100 mm 38 x 24 mm 81 x 52 mm
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10 mil 40 mm - 115 mm 34 x 22 mm 91 x 59 mm

15 mil 35 mm - 135 mm 30 x 20 mm 106 x 70 mm

20 mil 30 mm - 150 mm 27x18 mm 118 x 77 mm

* Note: The above table is the test results of the Grade A test card on the reader along the X
axis. The code resolution, contrast level and other environmental factors will affect the test
results.

Table17. BC50-K130R-MRS read distance (field of view at 130mm focal length: 95x60mm)

code system
exposure

time
gain

Barcode

resolution
Read the distance

Proximal

field of view

(horizontal x

vertical)

Distal FOV

(horizontal x

vertical)

Code39 500 us 4

6mil 90 - 155 mm 72 x 46 mm 119 x 77 mm

8mil 70 - 165 mm 56 x 36 mm 127 x 82 mm

12 mil 70 - 220 mm 56 x 36 mm 168 x 108 mm

20 mil 70 - 260 mm 56 x 36 mm 199 x 128 mm

Code128 500 us 4

6 mil 95 - 155 mm 77 x 49 mm 119 x 77 mm

8 mil 75 - 175 mm 72 x 46 mm 135 x 87 mm

12 mil 70 - 210 mm 66 x 42 mm 160 x 103 mm

20 mil 85 - 280 mm 68 x 44 mm 212 x 136 mm

Interleaved 2

of 5
500 us 4

8mil 80 - 170 mm 66 x 42 mm 131 x 85 mm

12mil 70 - 220 mm 56 x 36 mm 168 x 108 mm

20mil 70 - 310 mm 56 x 36 mm 235 x 150 mm

Data Matrix

(ECC200) 500 us 4

10 mil 90 - 165 mm 72 x 46 mm 127 x82 mm

15 mil 90 - 215 mm 72 x 46 mm 164 x 105 mm

20 mil 90 - 235 mm 72 x 46 mm 180 x 114 mm

* Note: The above table is the test results of the Grade A test card on the X axis of about 10
degrees of the reader. The resolution, contrast level and other environmental factors of the
code will affect the test results.

Table18. BC50-K200R-MRS read distance (field of view at 200mm focal length: 158 x100
mm)

code system
exposure

time
gain

Barcode

resolution
Read the distance

Proximal

field of view

(horizontal x

vertical)

Distal FOV

(horizontal x

vertical)

Code39 500 us 6
12 mil 100 - 220 mm 83 x 52 mm 173 x 109 mm

20 mil 90 - 320 mm 74 x 47 mm 248 x 157 mm

Code128 500 us 6 12 mil 100 - 215 mm 83 x 52 mm 169 x 107 mm
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13 mil 100 - 230 mm 83 x 52 mm 180 x 114 mm

15 mil 100 - 245 mm 83 x 52 mm 192 x 121 mm

20 mil 95 - 310 mm 79 x 50 mm 242 x 153 mm

Interleaved 2

of 5
500 us 6

12mil 100 - 210 mm 83 x 52 mm 165 x 105 mm

20mil 95 - 350 mm 79 x 50 mm 270 x 172 mm

24mil 90 - 415 mm 74 x 47 mm 320 x 204 mm

Data Matrix

(ECC200) 500 us 6

15 mil 125 - 215 mm 102 x 64 mm 169 x 107 mm

20 mil 120 - 250 mm 98 x 62 mm 195 x 124 mm

24 mil 120 - 270 mm 98 x 62 mm 210 x 133 mm

* Note: The above table is the test results of using the Grade A test card to tilt the code by
about 15 degrees on the X axis of the reader. The resolution, contrast level and other
environmental factors of the code will affect the test results.
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7 Packaging list and accessories
7.1 packing list

Table19. packing list
number content number

1 A BA (/ BC) 50 image-type code reader 1

2 mounting bracket 1

3 M2.5X4 Dishead self gasket screw 4

The dimensions of the readers and supports are shown in the section5.1hit the targetFig 2-Fig 4。

7.2 Optional accessories
Table20. Optional accessories

content model length Pin

Power supply & I / O
cables

17 core, M12
transfer fly line

MRSCAB-PIO-F02 2 m

MRSCAB-PIO-F05 5 m

1-Orange

2-Orange white

3-Black

4-Gray

5-Pink

6-Yellow

7-Green

8-White

9-Red

10-Purple

11-Red and white

12-Grey white

13-Blue

14-Black and white

15-Brown white

16-Blue and white

17-Brown

Ethernet cable
4 core, M12 to RJ 45

MRSCAB-ETH-M02 2 m
1-Orange white

2-Green and white

3-Orange

4-Green
MRSCAB-ETH-M05 5 m
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8 ELCO configurator Software interface
After opening the program, the software main interface such asFig 7As shown.

Fig7. Software main interface

The following functions are provided on the left side of the main interface:
 Automatic search: Automatic search for devices.
 Manual search: manually.
 Tool: for auxiliary test serial port and network communication.
 Help: Switch between languages and help documents.

On the right is the equipment information area and the task list area respectively. The device
information area shows the model number, serial number, and firmware version information of the
current connected device. The task list is related to the firmware updates for the configuration files
and devices.
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9 Find the device
ELCO configurator There are two optional device search methods for the communication
between the host and the reader: automatic search and manual search.

9.1 dead work
Before finding equipment and establishing communication, all:

Check 1: Confirm that the current firewall settings of the host do not hinder communication
between ELCO configurator software and device.

 If the host does not open the firewall, the communication between the software and the
device is not affected.

1. During the first run of ELCO configurator, the main opportunity popup alarm, e. gFig 8As
shown, select the appropriate network type (private or public network) and click Allow
Access.

Fig8. Windows Security Center alert

2. Follow the following guidelines to add ELCO configurator to the firewall.

a) Go to Start> Control Panel, for the Win10 system, you can enter "Control panel"
directly in the search box.

b) Enter all control panel items> Windows Defender Firewalls, e. gFig 9As shown.

c) Check the network currently connected (public or private).

d) Click to allow apps or features through the Windows Defender firewall.

e) Enter allowed applications and functions e. gFig 10As shown, click Change Settings.

f) Check the ELCO configurator application, and check the corresponding configuration
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 If the host has the firewall enabled, add ELCO configurator to the application and functions
allowed by the firewall to help the device connect.

according to the current network.

g) If the ELCO configurator does not appear in the list, allow another application to add
it to the list by clicking.

h) Click OK to save the changes.

Fig9The. Windows Defender Firewall

Fig10. Allowed applications and functions
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pay attention to

If the application is not added to the application and function allowed by the firewall, or the
network selected when adding the application is not the current connected network, an error will
be reported when connecting to the device, such asFig 11As shown.

Fig11. Starting the device communication session failed

Check 2: Ensure that the IP address of the reader is compatible with the host address, or
that the IP address of the reader is in the same network field as the address of the host.

 If the reader is directly connected to the host through the Ethernet port, the default IP address
of the reader is 192.168.5.25, and the IP address of the host shall be updated to 192.168.5.X.

a) If the IP address of the host is other fields within the 192.168.X.X range, it can be paired
by any of the following methods: 1) Change the IP address of the host to make it
compatible with the reader.2) The subnet mask is 255.255.0.0.

b) If you have modified the IP address of the reader, change the IP address of the host to the
matching address.

 If the reader is connected to the host via the server, query the IP address that the router
assigns to them and change the subnet mask of the host to 255.255.0.0.
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How to change the IP address of the host?

1. Enter the Start> Control Panel. For the Win10 system, you can directly enter "Control
Panel" in the search box.

2. Go to Network and Internet> Network and Internet> Network and Sharing Center>
Change Configurator settings.

3. Select the local connection network that is connected to the reader, and right-click the
properties.

4. in compliance withFig 12. As shown, go to the Internet Protocol Version 4 (TCP /
IPv4)> attribute.

5. Change the IP address and the subnet mask, and save it.

Fig12. Change the host IP address

9.2 automatic searching
1. in compliance withFig 13As shown, click AutoFind, ELCO configurator will find and list all

devices in the LAN network.

2. Select the device to be connected in the device selection area and click Connect to device

().

3. Once the connection is established, the details of the code reader are printed in the current
device details. All of the task options of the task list will become visible, as shown in FigFig
14。
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Fig13. interface

a) If you want to disconnect the device, click to disconnect the device ().

b) If you want to change the device environment variable, click on the.

Fig14. After connecting the equipment
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pay attention to

In the connection, the IP address of the reader should be compatible with the host, otherwise an
error will occur, such asFig 15As shown. Please the previous content for fault analysis.

Fig15. The network connection has failed

9.3 Manual search
1. Such asFig 16As shown, click Manual Find, in the pop-up window:

(1) Enter the IP address of the code reader. The factory-based default IP address is 192.162.5.25. If
you have changed the IP address of the reader, enter the appropriate correct IP address.

(2) If the host has multiple network cards, please select the host address that matches the code
reader, otherwise it will jump out of the boxFig 17Error reminder shown.

Fig16. Manually find the devices

2. After the device is found, click Connect to the device to realize the connection.

pay attention to

Make sure that the readers IP address is compatible with the hosts IP address.



Tianjin Eco Automation Co., Ltd 0 ELCO-USG-01 25

Fig17. Network connection failed

9.4 Edit Network Configuration
Click Edit Network Configuration () to configure the network environment parameters in the open

device environment configuration interface:

Fig18. Equipment environment configuration
 Change the IP address of the reader: Enter the appropriate IP address and the appropriate

gateway address.
 If the Subnet mask is 255.255.255.xxx, the last field of the Gateway Address cannot be

set to 255.
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10 task list
The task list on the main interface contains the following:

Fig19. task list

 Open the device configuration: set the configuration items of the reader, namely the
basic settings and the advanced configuration. Where: The basic setting focuses on the
image and decoding related configuration, including the general setting, decoding
configuration and data output format. Please refer to the chapter for details 11.2.
Advanced configuration is responsible for the configuration information related to the input
(trigger signal) output, including the configuration parameters of the internal trigger, RS232,
TCP / IP, PNP / NPN / N, Pro finet and other input and output. Please refer to the chapter for
details12Advanced configuration。

 Download configuration to computer: Save the current configuration information to the
local host, please refer to the section for details13maintenance。

 Update configuration to device: Update configuration items to device from local host,
see section for details13maintenance。

 Restore factory settings: restore the reader configuration to the default factory settings,
see section for details13maintenance。

 Download firmware to computer: Save the current firmware to the local host, please
refer to the section for details13maintenance。

 Update firmware to device: Update specified version of firmware to device from disk /
directory, see section for details13maintenance。
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11Basic Settings
Go to Task List> Open Device Configuration to the default basic settings page.in compliance
withFig 20As shown, the basic setting focuses on image and decoding related configuration,
including conventional settings, decoding configuration, data output format and statistical data
configuration.

Fig20. Basic Settings

In addition to the configuration of the above parameters, a row of function buttons is provided

above the image display area for the debugging of the configuration:

Cycle start

Continuous photography and decoding. Once enabled, the
icon switches to a cycle stop icon. Unable to modify the
image configuration and decoding parameters during loop
startup. If you want to modify, you should first click the pause
button before the subsequent operation.

Single start Single photography and decoding

Image saving
settings

Save the collected image to a local directory or a disk.
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Fig21. save the image
in compliance withFig 21As shown, you can configure the
image to be saved with the following options:
 Enable: If enabled, images that will automatically meet

the currently configured types and conditions during the
drawing.

 Type: To determine the format of the image preservation
(. BMP,. PNG perhaps. JPG).

 Condition: Determine which images will be saved (all
images, successful or failed images).

Amplification
display

Image is displayed by zoom-in. As shown, in the upper right
corner of the image is provided a thumbnail of the image
display area, where the red box shows the range of the current
image display area.

1) Change the display area by dragging the slider (below and
right) and the red box in the upper right corner.
2) The size of the display area can be changed by clicking the
proportional display icon and reducing the display icon.

Equal proportions
are shown

Display by actual image size (default)

Minimize the
display

Shout display image, effective on enlarge display only.
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FTP download

Download the images on the reader ontology FTP server
locally.

Fig22. Download images
in compliance withFig 22As shown, select the path for the
image saved (folder must be empty) and click Download.
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11.1 The regular setting
in compliance withFig 23, General settings include image size, pixel fusion, and image mirrors.

 Image size: Cut the image by entering a numerical value or by dragging the blue
selection box.

 Box Start X: Defines the horizontal coordinates (in pixels) in the upper left corner of the
image cut area.

 Box starting point Y: Defines the vertical coordinates (in pixels) in the upper left corner of
the image cut area.

 Box width: Defines the width of the image cut area (in pixels).

 Box height: Defines the height of the image clipping area (in pixels).

 Pixel fusion: do 2x2 fusion of images.

 Vertical mirror: processes and displays reflections along the vertical direction.

 Horizontal mirror: processes and displays reflections along the horizontal direction.

Fig23. Regular Settings

11.2 Decode configuration
Five sets of image settings are provided in the decoding configuration. When decoding, the
software will execute the selected image setting group until the decoding is successful, and the
decoding result status is red, green and yellow (red: decoding failure; green: successful decoding;
yellow: unset decoding).
For example, such asFig 24As shown, because only group 2 parameters are enabled and decoded
successfully, only the parameter configuration of image setting group 2 takes valid and group 2 is
marked green.
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Fig24. Decode configuration

If 1,2, and 3 are checked simultaneously, the multiple sets of parameters are enabled: image
set group 1: set the decoding failure, image set group 2: set the code successfully, set the
software will first execute the image set group 1, and then execute the image set group 3,
group 2 without the code does not take the drawing.
in compliance withFig 25As shown, because group 1 failed, group 2 failed not taken, and
group 3 was decoded, group 1 is marked red, Group 2 yellow, and Group 3 green.

Fig25. Enables multiple image parameter groups

11.2.1 Image setting group
Each parameter group includes image settings, image algorithm configuration and barcode settings,
and both can be manually configured separately. The image setting contains all the parameters
related to the image quality, the image algorithm configuration provides some decoding image
pre-processing method that can be used to help to read better, and the barcode setting is used to
select the type of barcode.
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In addition, to help with the configuration, the software provides the barcode automatic teaching
function, including the image automatic setting and the code self-learning function. The specific
operations are performed as follows:
1. Click the barcode under the selected image setting group.
2. In the open barcode auto display interface, select the barcode type to be decoded.
3. Click Start and wait for the current progress to become 100%.
4. Click Yes in the save results interface to save the current results, e. gFig 26。

Fig26. Bar code automatic teaching

11.2.1.1 Image Settings

Fig27. Image Settings

Image quality was determined by exposure time, gain and fill light settings.as shown in the
figureFig 27As shown, using the image setting group 2 as an example, the image setting can be
automatically configured by the system (image automatic setting) or the image quality parameters
can be manually adjusted:

 Image automatic setting: the software automatically adjusts the image parameters.
Specific operations such asFig 28As shown.
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Fig28. Image auto set

 Exposure time (μ s): defines the time interval at which the CMOS sensor receives
the optical signal. The setting of the exposure time should be adjusted according
to the environmental state (lighting, barcode contrast, material reflection,
movement, etc.). Usually, long exposure can produce brighter images but cause
barcode to become blurred.

 Gain: The image can be illuminated / dimmed by adjusting the size of the gain. The
size of the gain was changed from 1 x to 16 x. Increasing the gain brings a
brighter image, but also blur the image.

 Light light setting: Auxiliary lighting can be provided through built-in LED lights.
The lighting system is composed of 4 LED lights, and it can be controlled
independently. The optional lighting modes are:

1) Upper strostrobe: only the upper light source is turned on in strobe mode.

2) Lower strobe: Only on the lower light source in strobe mode.

3) Up and down strostrobe: turn on all light sources in strobe mode.

4) Chang Liang: Turn on all the light sources in the normal bright mode.

5) Often go out: turn off all the lights.

pay attention to

1) If the image or barcode area is too dark, the user can increase the visibility of the image
by increasing the exposure time and gain.

2) The brightness of the image is determined by the exposure time, gain and fill light. Once
one of the parameters, review the other parameters for best image quality.
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11.2.1.2 Image algorithm configuration

in compliance withFig 29As shown, the image algorithm configuration provides some image
preprocessing methods, such as:

Fig29. Image algorithm configuration

 Contrast degree pull deep

 median filtering

 smoothing filtering

 expand

 corrode

 Open the operation

 closed operation

 Bright area enhancement

 Dark zone enhancement

 sharpen

 histogram equalization

 Vertical mirror image

 Horizontal mirror image
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pay attention to

The filter size is required when performing median filtering, smooth filtering, expansion,
corrosion, open operation, and close operation. Different filter sizes determine how many pixels in
the size range around each image pixel will participate in the calculation.

At the same time, for better decoding, some other decoding-related parameters are also configured
in the decoding configuration:

 DPM code: to decide whether to enable the DPM code.

 Barcode contrast: define the symbol contrast threshold to be used during decoding, and
the decoding time may be reduced by setting high contrast values for very high contrast
symbols.

 Barcode size: allows to read any size type of DataMatrix code (automatic), square,
rectangle, or accurately set the number of modules of the DataMatrix code to be read
(custom).

 Barcode color: determines whether the color of the barcode is black or white.

 Bar code direction: Decode the one-dimensional code in the specified direction.

 Decoding complexity: Set the decoding complexity of the selected system of the current
setting group. The higher the complexity, the longer the decoding time is required.

 Decoding time (milliseconds): Set the total decoding time for the selected system of the
current setting group.

 Decoding area: Select the appropriate decoding area by entering a numerical value or
dragging the red selection box.

11.2.1.3 Barcode Settings

In the barcode setting, the automatic configuration of barcode types and decoding algorithm
parameters can be realized through code self-learning. The specific operation is shown in FigFig
30As shown:
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Fig30. Code for self-learning

Furthermore, the software supports manual detailed settings for each specific barcode type, e. gFig
31As shown:

Fig31. Barcode Settings

- Expected content: Allow to check whether the decoded content matches the expected
content. If consistent, the read will be considered a good read, otherwise it will be
considered a read failure. The test criteria support the use of the wildcard character *.

- Search code number range: the number of barcodes allowed to be decoded by the
barcode type. You can enter a number or drag a double slider for selection. The decoding
is considered to fail if the number of successful barcodes is not within the search number.

- Character number range: the character length of the barcode information. You can
enter a number or drag a double slider for selection.

The above three parameters are more focused on evaluating the decoding results of the same code
system (good read or failed read).

11.3 Data output format
The final output information depends entirely on the configured barcode settings (see
section11.2.1.3), And the data-output format.



Tianjin Eco Automation Co., Ltd 0 ELCO-USG-01 37

Fig32. Data output format

The Data output format defines the format of the output information. The output
information format is mainly composed of start character, decoding information, end
character, decoding state, total number of decoding, total decoding time and output data
template. It consists of the following contents:

 Output starter

 Output end

 Decoding failed prompt

 Enable the barcode output separator

 Multiple barcode separator: Visible after the barcode output separator is enabled.

Here, when setting the start, end, and decoding failure prompt, click the rear C key and click the
corresponding character from the outgoing ASCII table, seeFig 33：
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Fig33. Set the output information start / end / failure prompt

 Part of the read:

Enable the barcode type partial reading

Enable barcode number section reading: complement the missing part with
decoding failure character

give an example
1. For a single barcode scenario:

If the decoding content is ABCD123456, output start = <STX>, output end = <85>, decoding
failure prompt = <86>:
 Decode the expected content

 If decoding the expected content =AB *, which matches the decoding content and is
considered a good read, then the output information is <STX>ABCD123456 <85>.

 If the decoding expected content =AB * 7, then the decoding content does not
match and the read is considered to fail, then the output result is <STX> <86>
<85>.

2. For the scenario of multiple barcodes (2 barcodes with the same code):
If the barcode information is ABC123, ABCD456, output start = <STX>, output end = <85>,
decoding failure prompt = <86>, multiple barcode separator =%:
 Search code number range is 2-2:

 If both barcodes are decoded, the output information is <STX>
ABC123%ABCD456 <85>.

 If only the ABC123 is solved:
Enable barcode number part read: the output information is <STX>

ABCD123 <85>
Enable the barcode number section reading,
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Enable to complement the missing part with the decoding failure character:
the output information is <STX> ABCD123% <86> <85> (complement the
decoding failure with the failure character).

Disable barcode number part reading: if the read is considered failed, the
output result is <STX> <86> <85>.

3. For multiple barcode (2) different code system scenarios:

If the barcode information is EAN123, and ECC456, output start = <STX>, output end =
<85>, decoding failure prompt = <86>, multiple barcode delimiter =%. If only the decoding
gives the EAN123:

 Enable barcode type partial reading: the output information is <STX>
EAN123 <85>.

 Disable barcode type reading: output is <STX> <86> <85>.
If the expected content is simultaneously configured: the information EAN123 of the barcode
1 matches the expected content, and the information ECC456 of the barcode 2 does not match
the expected content:

 Enable barcode type partial reading: the output information is <STX>
<86>%EAN123 <85> (complement the successful decoding result but does not
meet the expected content).

 Disable barcode type reading: output is <STX> <86> <85>.

 Decoded state output:

Decoding state output mode: users can choose to enable or disable decoding
state output, output mode includes character output, bit output.

If you select the character output, in the setting, click the rear C button behind, and
click the corresponding character from the outgoing ASCII table, seeFig 34：

Successful Read: Deine the character successfully decoded

Failed read: defines the character of the failed decoding output

Fig34. Set the character output of the decoding state
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If the bit output is selected, when the successful reading is set, check the check box
of the output bit. The default output bit of the successful read is the first digit, and the
default output bit is the first digit, seeFig 35：

Fig35. Set the bit output for the decoding state

 Decode total quantity output: seeFig 32, Users can choose to enable or disable the function,
if enabled, output the total number of decoding.

give an example:

Bar code setting enable ECC200 (search code range: 1-1), EAN (search code range: 2-3),
CODABAR (search code range: 1-1), front code enable decoding successful 1 ECC200 (code
information is: abc123), 1 EAN (code information: 56897005), enable bar code type part reading,
barcode data part read and decoding failure to complement the missing part, the separator is: / /, if
enable decoding total number output, will output the following content:

<Start> 4 / / abc123 / / Fail / / Fail / / 56897005 <End>

 Decoded total time output: seeFig 32, The user can choose to enable or disable the function
and, if enabled, will output the total decoding time: the total consumption time in the
received decoding information, in the following format:

<Start> 230... <Code information>... <Finder>

Note: If the decoding state output is enabled, the total quantity data and the total time
output, the output format is as follows:
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<Start> <Decoding Status> <> Separator> <Total Number of Decoding> <separator> <Total
Decoding Time> <Separator>> Code <Information> <End>

 Output data template: When setting the output data template, click the rear B button,
and select the corresponding type from the outgoing window. The default output data
template: {code_content}, seeFig 36。

Fig36. Set up the output data template

The output data template contains:

Code _ content: If configured, the code,

Code _ type: If configured, the barcode type is output,

Code _ pos: If configured, the coordinates of the barcode,

decode_length: If configured, the length of the code is output.

If the output data template is configured as: {code_content} {code_type} {code_pos}
{decode_length},

The output format is as follows:

<Start> <Code Information> <separator> <Type of Code> <separator> <Code coordinates>
<separator>> <Length of Code>> End>

Note: The output is in the same order as the configuration type.

11.4 Statistical data configuration
The display of decoding statistical data is determined by the configuration of statistical data. The
default enabling items are: decoding success rate (%), statistical time (seconds), decoding success
count, decoding failure count, and drawing count, seeFig 37：
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Fig37. Statistical configuration

 Decoding success rate (%): the number of successful decoding times / the number of triggers

 Statistics time (seconds): the time elapsed after the start of the statistics

 Decoded success count: number of successful ded success

 Decoding failure count: the number of decoding failures

 Drawing count: the number of total drawings

 Frame rate: number of drawings per second

 Number of triggers: Total number of triggers

 Average decoding time (milliseconds): the average of the last ten decoding times

 Phase Open Count: The count that triggers a phase opening

 Average image acquisition time (milliseconds): the last ten readers averaged the image time

 Average image processing time (milliseconds): Average decoding time + average image
acquisition time
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12 Advanced configuration
The BA (/ BC) 50 series code reader supports internal triggering and multiple hardware triggering
and communications, such as TCP / IP, RS 232 serial port, and hardware PNP / NPN input and
output. These settings can all be done in an advanced configuration.

Fig38. Advanced configuration

pay attention to

1. Reference to the section before performing the input / output communication configuration5.2,
Complete the hardware connection.

2. as shown in the figureFig 38As shown, click on the Advanced Configuration to enter the input
/ output configuration page.

12.1 Enter the configuration
BA (/ BC) 50 supports both trigger mode and phase mode.among:

 trigger mode:

Continuous mode, period (milliseconds): the user defines when and
triggers the cycle.

External trigger: triggered by connected external trigger signals.

 Phase mode:

That is, the gating trigger allows the device to collect single or multiple images
within a given range Code results.
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12.1.1 trigger mode
Trigger mode includes continuous mode (default), period (milliseconds), and external
trigger.

Fig39. trigger mode

 Continuous mode (by default):

In continuous trigger mode, the reader performs mapping and decoding at the default frame
rate.

 Cycle (in milliseconds):

If the cycle mode is enabled, the user can set the cycle interval time by itself.

 External trigger:

BA (/ BC) 50 provides a variety of external triggers, such as: hardware PNP / NPN trigger,
Ethernet TCP / IP trigger, RS232 serial port trigger, industrial Ethernet Profinet trigger,
industrial Ethernet Ethernet / IThe P trigger and the Modbus TCP trigger.

Trigger signal delay (milliseconds): If the trigger delay is enabled, the corresponding
delay time can be set.

12.1.1.1 Hardware PNP / NPN trigger

BA (/ BC) 50 supports up to two hardware PNP / NPN input. This input type (PNP or NPN)
depends entirely on how the hardware is wired. Before the configuration, refer to the
section5.2Complete the hardware connection.among

 Hardware input 1: corresponds to the DIN _ 1 in the table.

 Hardware input 2: corresponds to the DIN _ 2 in the table.
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Fig40. External trigger

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Complete the following input configuration based on the hardware connection mode.

Enable the input 1 or 2 trigger configuration: enable the hardware interface
corresponding to the hardware input connection mode. If the hardware interface of the
trigger signal is connected as DIN _ 1, the input 1 trigger configuration is enabled.
Otherwise, enable the input 2 trigger configuration.

 Signal trigger mode: Use the leading edge of the trigger as the trigger.

graphFig 41A configuration schematic based on an external trigger triggered by input 2 is given
in.

Fig41. Hardware input: an external trigger mode

12.1.1.2 The Ethernet TCP / IP trigger

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. When the device is triggered by an external Ethernet signal, it can be used as a TCP server or
as a client.

 Enable TCP Server: If enabled, the reader can be triggered as a TCP server.
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 Local port: the listening port number of the code reader, and the port setting
range is: 10000-65536.

 Max customer: the maximum number of devices allowed to connect.

 Trigger information: the trigger information used to trigger the drawing. Click
the C button and select the trigger information in the ASCII code table
jumping out. The reader is triggered only triggered when the content of the
trigger information is consistent with it.

Fig42. Ethernet trigger-The code reader acts as a TCP server

 Enable TCP Client: If enabled, the reader will be triggered as a TCP client.

 Host IP address

 Host port: the port that the host listens for.

 Reconnection interval (ms): Reconnection time when the device connection
failed.

 Trigger information: It is used to trigger the drawing drawing. Click the C
button and select the trigger information in the ASCII code table jumping out.
The reader is triggered only triggered when the content of the trigger
information is consistent with it.

Fig43. Ethernet trigger-The code reader acts as a TCP client
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pay attention to

To ensure a successful connection, make sure that the configured port number is not occupied.

12.1.1.3 The RS232 serial port trigger

Fig44. RS232 Trigger the configuration

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the serial port trigger configuration, check the enabled serial port.

4. Set the trigger information: click the C button to select the trigger information from the ASCII
code table. The reader is triggered only triggered when the content of the trigger information
is consistent with it.

5. In the RS232 configuration, select the corresponding RS232 serial port parameter,
referenceFig 44。

12.1.1.4 Industrial Ethernet Profinet trigger

BA (/ BC) 50 supports two trigger modes, character trigger and bit trigger. The specific
configuration instructions are as follows:

 The PLC uses the character trigger mode to trigger the code reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the P rofinet trigger configuration, check to enable the P rofinet trigger.
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4. Select a character trigger in the Pr ofinet trigger type.

5. Set the trigger information: click the C button to select the trigger information from the ASCII
code table. The reader is triggered only triggered when the content of the trigger information
is consistent with it.

Fig45. Profinet trigger- -character trigger

 The PLC uses the bit trigger mode to trigger the reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the P rofinet trigger configuration, check to enable the P rofinet trigger.

4. Select a bit trigger in the Pr ofinet trigger type.

5. Set the input bits for the bit trigger: tick the single or multiple trigger bits. As long as a single
input bit or multiple input bits are included in the output setting of the PLC, the reader is
considered triggered.
Note: Position 1 is only a clearance position.
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Fig46. Profinet trigger- -bit trigger

Refer to the sections on how to configure the PLC devices12.5.1。

12.1.1.5 Industrial Ethernet Ethernet / IP trigger

BA (/ BC) 50 supports two trigger modes, character trigger and bit trigger. The specific
configuration instructions are as follows:

 The PLC uses the character trigger mode to trigger the code reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the Ethernet / IP trigger configuration, check to enable the Ethernet / IP trigger.

4. Select the character trigger in the Ethernet / IP trigger type.

5. Set the trigger information: click the C button to select the trigger information from the ASCII
code table. The reader is triggered only triggered when the content of the trigger information
is consistent with it.
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Fig47. Ethernet / IP Trigger- -character trigger

 The PLC uses the bit trigger mode to trigger the reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

Fig48. Ethernet / IP trigger-bit trigger

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the Ethernet / IP trigger configuration, check to enable the Ethernet / IP trigger.

4. Select a bit trigger in the Ethernet / IP trigger type.

5. Set the input bits for the bit trigger: tick the single or multiple trigger bits. As long as a single
input bit or multiple input bits are included in the output setting of the PLC, the reader is
considered triggered.
Note: Position 1 is only a clearance position.

Refer to the sections on how to configure the PLC devices12.5.2。
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12.1.1.6 Modbus TCP From the machine

BA (/ BC) 50 supports two trigger modes, character trigger and bit trigger. The specific
configuration instructions are as follows:

 Modbus TCP The slave machine uses the character trigger mode to trigger the code reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the Modbus TCP slave trigger configuration, check to enable the Modbus TCP slave
trigger.

4. Select a character trigger in the Modbus TCP slave trigger type.

5. Set the trigger information: click the C button to select the trigger information from the ASCII
code table. The reader is triggered only triggered when the content of the trigger information
is consistent with it.

Fig49. Modbus TCP slave trigger type-character trigger

 Modbus TCP The slave uses the bit trigger mode to trigger the reader

1. Go to Advanced Configuration> Input Configuration, select Trigger Mode> External Trigger
in Trigger Signal Type.
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Fig50. Modbus TCP slave trigger type-bit trigger

2. Enable the signal trigger delay: whether the trigger signal is delayed.

3. Under the Modbus TCP slave trigger configuration, check to enable the Modbus TCP slave
trigger.

4. Select a bit trigger in the Modbus TCP slave trigger type.

5. Set the input bits for the bit trigger: tick the single or multiple trigger bits. As long as a single
input bit or multiple input bits are included in the output setting of the Modbus TCP, the
reader is considered triggered.
Note: Position 1 is only.

Refer to the section on how to configure the Modbus12.6。

12.1.2Phase mode
Phase mode includes phase trigger settings: phase on, phase off, and trigger type settings.

Fig51. Phase mode
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Phase-trigger settings:

1. Go to Advanced Configuration> Input Configuration, select Phase Mode in the Trigger
Signal Type.

2. Configure the phase trigger:

 Phase opening: determines the starting position of the trigger signal.

include:

Enter 1 to trigger the configuration

Enter 2 to trigger the configuration

The code reader acts as a TCP server

The code reader acts as a TCP client

gorge line

PROFINET

Fig52. Phase open

Refer to the section for the specific configuration of the phase start type12.1.1。

 Phase off: determines the end position of the trigger signal.

include:

Enter 1 to trigger the configuration

Enter 2 to trigger the configuration

The code reader acts as a TCP server

The code reader acts as a TCP client

gorge line

PROFINET

overtime:

If timeout, set the corresponding timeout time.
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Fig53. Phase closure

Refer to the section for the specific configuration of the phase shutdown type12.1.1。

 Phase-wise output mode:

 To Enable the fusion output: To decide whether to enable the fusion output. If
enabled, during the phase opening, the reader continuously reads the read code
until the phase is off, and the repeat code is output only once.

 Enable successful reading: to decide whether to enable successful reading. If
enabled, the phase off and output after reading the successfully configured code
number, if not enabled, the phase is not automatically closed until the phase off
signal, phase off and output.

 Number of successful reads: Configure the number of successful reads.

 Fill the missing part with decoding failure: If enabled and the number of successful
reads does not reach the configured number of successful reads, the missing part is
filled with failure.

 Enable coordinate sequence output: If enabled, the content is decoded in the
configured order. Coordinate order output contains two types: left to right, up to
down:

Left to right: output the X-axis coordinates of the vertex in the upper right corner
of the barcode.

Up to bottom: output the Y axis coordinates of the vertex in the upper right corner
of the barcode.

Fig54. Phase-wise output mode
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 Trigger type setting: Select a trigger type.

 Continuous mode

 Cycle (millisecond)

 External trigger

Fig55. Trigger type

Refer to the section for the specific configuration of the trigger type12.1.1。

pay attention to:

Enable the reader as a TCP server or client, and to ensure a successful connection, make sure
that the configured port number is not occupied.

12.2 Output configuration
BA (/ BC) 50 supports a variety of output interfaces, such as RS232 serial port, TCP / IP,
Profinet, and hardware output. The output configuration can be set in the Advanced
Configuration> Output Configuration:

 Output information configuration: Configure the RS232 serial port, TCP / IP (client
and server), and Profinet.

 Hardware output configuration: control two hardware PNP / NPN output at the
same time.

12.2.1RS232 Serial port output
1. Go to Advanced Configuration> Output Configuration> Output Information Configuration,

select serial port in output interface type.

2. In the RS232 configuration, select the corresponding RS232 serial port parameter,
referenceFig 56。
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Fig56. Serial port output

12.2.2The Ethernet TCP / IP output
The reader can output data as both a TCP server and a client.

 Output by TCP server: output through the TCP server port of the reader.

1. Go to Advanced Configuration> Output Configuration> Output Information
Configuration, select the TCP server in the Output Interface Type.

2. Configure the TCP server parameters:

Local port: the listening port number of the code reader.

Max customer: the maximum number of devices allowed to connect.

Fig57. Output the data with the TCP server side port

 Output in TCP client: output through the TCP client port of the reader.

1. Go to Advanced Configuration> Output Configuration> Output Information
Configuration and select TCP Client from Output Interface Type.

2. Configure the TCP client parameters:

Remote IP address

Remote port

Reconnection interval (milliseconds): Reconnection time when the device
connection failed.

Fig58. Output data on the TCP client port
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pay attention to

To ensure a successful connection, make sure that the configured port number is not occupied.

12.2.3 Industrial Ethernet Pro finet output
When the code reader acts as the input signal source of the PLC device and outputs the signal to it,
both the PLC device and the code reader should be configured. For the specific configuration,
please refer to the following instructions:

Refer to the sections on how to configure the PLC devices12.5.1。

pay attention to

The same BA (/ BC) 50 device can only support one output module, so only one input module can
be configured in the relevant configuration of the PLC to communicate with the reader.

The output configuration of the BA (/ BC) 50 reader refers to:

1. Go to Advanced Configuration> Output Configuration> Output Information Configuration
and select P rofinet in the Output Interface Type.

2. Profinet Configuration, with reference toFig 59：

 Select the appropriate number of PLC registers reserved.

Fig59. Pro finet Output configuration

pay attention to

The number of PLC register reserved in the reader must coincide with the size of the input module
of the PLC.
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12.2.4 Industrial Ethernet Ethernet / IP (EIP) output
When the code reader acts as the input signal source of the PLC device and outputs the signal to it,
both the PLC device and the code reader should be configured.

Refer to the sections on how to configure the PLC devices12.5.1。

The output configuration of the BA (/ BC) 50 reader is as follows:

Go to Advanced Configuration> Output Configuration> Output Information Configuration, select
Ethernet / IP in the output interface type, seeFig 60。

Fig60The. Ethernet / IP output configuration

12.2.5Modbus TCP Deliver from the machine output
The output configuration of the BA (/ BC) 50 reader is as follows:

Go to Advanced Configuration> Output Configuration> Output Information Configuration, select
the Modbus TCP slave in the output interface type. SeeFig 61：

Fig61. Modbus TCP slave output configuration

Refer to the section on how to configure the Modbus12.6。

12.2.6Hardware PNP / NPN output
1. in compliance withFig 62As shown, the code reader provides two modes of hardware output.

The output mode (PNP or NPN) depends entirely on the wiring mode of the hardware. Before
the configuration, refer to the section5.2Complete the hardware connection.among

 Hardware output 1: corresponding to DOUT _ 1.

 Hardware output 2: corresponding to DOUT _ 2.
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2. Enter the Advanced Configuration> Output Configuration and enable the corresponding
hardware interface based on the hardware connection mode.

3. Set the configuration for the selected output.

 Pulse width (milliseconds): Continuous width of the output pulse signal.

 Trigger event: decide to output a signal on reading success or reading failure and use it
as a trigger for a subsequent device.

Fig62. Hardware output configuration

12.3 Networking mode
BA (/ BC) 50 supports the networking mode. Users can enable the networking and select the
master-slave mode:

Fig63. Networking-host mode
 Host mode:

 Number of slave: maximum number of slave allowed, effective value threshold: 1-6.
 Local port: The port number with the setting range of 8880-9999.

Note: To ensure a successful connection, please ensure that:
1. The configured port number is not occupied.
2. The trigger mode of the host can be: input configuration-> continuous mode, input
configuration-> cycle mode, input configuration-> external trigger.
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Fig64. Networking- -slave mode

 From machine mode:
 Host IPAddress: It is configured as the IP address of the host
 Host Port: Port number configured for the host

After networking success:
1. The input and output of the slave are invalid, the slave shares the trigger signal of the host, and
a reader can read the data and output by the host. The NG information is only uploaded when all
the information is NG.
2. Output in the data output format of the host.
3. Support one master and slave, the maximum number of slave allowed is 6.

12.4 FTP configure
BA (/ BC) 50 supports image preservation as an FTP server

Fig65.FTP configure

as shown in the figureFig 65As shown, you can configure the image to be saved by the following:
 Enable FTP: If enabled, save the image in offline mode, and the image is saved in the reader

ontology FTP server
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 Image type: determines which images will be saved (all images, decoded successfully images,
or decoded fail images)

 Number of pictures: number of saved pictures, effective value threshold: 5-200
 Image format: decide the format of the image saved (. JPG or. BMP)

FTP download

Download the images saved on the native FTP server to the local
directory or disk while exporting the configuration files.

Fig66.FTP download

Note: If the selected directory is not empty, empty it first

Fig67. Empty the download folder

12.5 PLC configure
1. Rereference before configthe PLCFig 68, Complete the hardware connection between the

PLC and the BA (/ BC) 50 series code readers.
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Fig68. Schematic diagram of the PLC wiring

2. Refer to chapter12.1And chapter12.2, Arrange the input / output function of the BA (/ BC) 50
reader accordingly.

3. Refer to chapter9.4, Confirm the IP address of the current BA (/ BC) 50 reader in the LAN (e.
g. 192.168.0.30).

12.5.1Profinet linkage
Taking the PLC equipment model: S7-1200, equipment BC50 series as an example, the Profinet
configuration details of the PLC are described below.

1. in compliance withFig 69As shown, open the Management General Site Description file
(GSD) under the selection menu, import the BC50 GSD file from the computer folder, and
then click Install.

Fig69. PLC Profinet-Import the GSD file in the PLC

2. Click on the green network port of the PLC icon to enter the general Settings of the PLC
module (seeFig 70), Confirm whether the IP address of PLC belongs to the IP address of
BC50 to realize the connection between BC50 and PLC. If not, modify the IP address of the
PLC.
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Fig70. PLC Profinet-Set up and confirm the IP address of the PLC

3. in compliance withFig 71As shown, return to the device and network interface and manually
drag the added BC50> BC50 on the right device list to the network configuration screen on
the left.

Fig71. PLC Profinet-Manually drag the BC50 reader into the network configuration

4. in compliance withFig 72As shown, click the unassigned interface in the network
configuration BC50 icon on the right, select the PROFINET interface corresponding to PLC
(PLC _1 _ PROFINET interface _ 1 in the figure), and a green connection line will appear in
the icon of PLC and BC50.

Fig72. PLC Profinet-Connect PLC with BC50 reader through Profinet interface

5. in compliance withFig 73As shown, double-click the green network port of the BC50 icon to
change the IP address to the current IP address of the BC50 reader (such as 192.168.0.30).
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Fig73. PLC Profinet-Set the IP address of the reader for the P rofinet connection with the PLC

6. in compliance withFig 74As shown, cancel "automatically generate PROFINET device
name" and name BC50 manually (set as BC50-001 in the figure) to distinguish it from other
devices.

Fig74. PLC Profinet-Manual naming for the BC50 code reader

7. Double-click the icon of the BC50 to enter the separate hardware Settings interface (seeFig
75), Then right-click the BC50 icon and select the assigned device name.

Fig75. PLC Profinet-Configure the device name for the BC50 code reader

8. in compliance withFig 76As shown, in the jump-out window, select the interface type for
online access as PN / IE, click on the update list, and search for the BC50 hardware. Select
the BC50 hardware and click Assign Name to assign the new name BC50-001 to the BC50
sensor in the network.
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Fig76. PLC Profinet-Assign the PROFINET device names

9. Click Online, select PLC device (such as PLC _ 1), click "Go to Online", asFig 77As shown.

Fig77. PLC Profinet-PLC transferred to online

10. in compliance withFig 78As shown, in offline mode, select the PLC device connected to the
BC50 code reader, and right-click to download all the hardware and software configurations.
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Fig78. PLC Pr ofinet-Download the current configuration to the device

11. After downloading the parameters, you can see that all the devices are displayed in green,
indicating that the PLC and the BC50 readers are truly connected. If the device displays red,
it should be not set incorrectly and need to use diagnostic information to check.

Fig79The. PLC Profinet-PLC was successfully connected with the BC50 code reader

12. When configuring the input and output of the PLC, you need to view the input and output
address of the PLC device. The following example, PLC is 64 bytes input and 8 bytes output,
where the input address is% I132-%I195 and the output address is%Q76-%Q83.

Fig80. PLC Profinet-PLC input / input output
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 BC50 reader as input to PLC:

 The number of PLC registers set at the Profinet output of the BC50 reader (see section12.2.3)
Consiconsistent with the address interval of the PLC input. If the BC50 Profinet output
register reserves 64 PLC, the PLC is a 64-byte input (the input address field
is%I132-%I195). If you need to modify the input address interval of the PLC, you need to
modify the save in offline mode and download the current configuration to the PLC
device.

 If the output of the reader is 16ECCABC123, and the input address of the PLC starts at%I132,
then the value detected in the PLC is:

%I132 1

%I133 6

%I134 E

%I135 C

%I136 C

.. ..

Table21.BC50 reader as PLC Profinet input

 The PLC triggers the BC50 code reader:

 The BC50 reader triggers in bit-trigger mode

1. Determine the Profinet-bit trigger (see section12.1.1.4) The corresponding PLC output
address. For example, in this case, since the output of the PLC starts from%Q76, the
address of the X-bit trigger pair is%Q76.X, and the address of the third bit trigger
is%76.3. If multiple trigger bits (e. g. 0 and 3 bits) are checked simultaneously, the
corresponding addresses are%76.0 and%76.3.

Note: Position 1 is only a clearance position.

2. Set the parameter value of the address corresponding to the trigger bit: the display format
corresponding to the modified trigger bit is Boolean type, and then the modified value is
set to True.

3. Write the above configuration to ensure that the above configuration takes effective.
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Fig81. PLC-View the real-time data emitted by the BC50 reader

 The BC50 reader triggers in character trigger mode

1. Determine the Profinet character trigger (see section12.1.1.4) The first output address of
the corresponding PLC. For example, in this case, since the output of the PLC starts
at%Q76, the corresponding address for the character trigger pair is% QB 76.

2. Sets the display type for the trigger address: Character.

3. Set the trigger character for the trigger address: Set the trigger character in the modify
value bar (with the chapter12.1.1.4The trigger characters set in are consistent).

4. Write to all of the current configurations.

Fig82. PLC-BC50 reader triggers in character trigger mode
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pay attention to

1. The same BC50 device only supports only one input module, so only one output
module for the communication part associated with the PLC can be configured.

2. Only when any byte in the PLC configuration output module changes will the reader
device receive the contents of the PLC output module and be continuously triggered.

12.5.2The PLC Et hernet / IP (EIP) configuration
Taking the PLC equipment model: OMRON NX1P2-9024DT, equipment BC50 series as an
example, the EIP configuration of PLC is introduced in detail.

1. as illustrated in following figureFig 83As shown, click on Tools> EtherNet / IP Connect
Settings (N).

Fig83. PLC EIP-Enter the EIP connection settings

2. in compliance withFig 84As shown, in all the PLC devices in the current LAN listed,
double-click the record in the list to enter the built-in EtherNet / IP port setting connection
settings interface.

Fig84. PLC EIP-EIP equipment list record

3. in compliance withFig 85As shown, in the toolbox on the right, right-select the EDS library.
Click install in the EDS page, and select the eds file in the file browser window,
EIP_ELCO_BC50_XXX.eds.
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Fig85. PLC EIP-shows the EDS library

4. in compliance withFig 86As shown, after installing EIP _ ELCO _ BC50_XXX.eds
successfully, the BC50 can be seen in the EDS library in the right side window.

Fig86The. PLC EIP-eds file was installed successfully

4. Click the Add Target device on the right (seeFig 87), In the toolbox on the right, set the node
address: 192.168.250.111 (IP address of BC50 equipment), model name: BC50, revision: 2,
egFig 88。

Fig87. PLC EIP-Add the target device

Fig88. PLC EIP-Set the target device information

Note: To ensure available communication, please configure the IP of the PC, PLC, and BC50
devices for the same network segment.

5. in compliance withFig 89As shown, click Programming> Data> Global Variable, right-click
new, and create a two-byte array.
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Fig89. PLC EIP-Set the global variable input and output

6. Click on Configuration and Settings> Task Settings, and click on the VAR icon in the Task
Settings interface.in compliance withFig 90As shown, click the icon + in the outgoing
interface, select the new global variables INT128 and OUT 8 in the previous step, and add
them to the main task Primary Task for real-time monitoring.

Fig 90. PLC EIP-Add the global variable to the main task

7. in compliance withFig 91As shown, in the built-in EtherNet / IP port setting connection
setting interface, click All Register. And in the outgoing interface (seeFig 92), Select all
variables and click Register.

Fig91. PLC EIP-Register the global variable
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Fig92. PLC EIP-Registration setting interface

8. On the input / output page, right-click and select "Create a new label group" to
configure the input and output respectively, with the data configuration as shown in the
picture.

Fig93. PLC EIP-Set up the input information

Fig94. PLC EIP-Set up the output information

9. Click tool> EtherNet / IP Connection Settings (N). In the built-in EtherNet / IP port setting
connection setting interface, click the left connection icon, open the connection configuration
interface, click the "+" button, select the pull-down data in the target device, and configure the
target variable. The starting variable is shown in the figure.

Fig95. PLC EIP-Go into the connection interface
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10. in compliance withFig 96As shown, click +, select the configured device in the target device,
and set the target variable, size [bytes], the starting variable to bind the global variable to the
connected device.

Fig96. PLC EIP-Configure the connected devices

11. Click Controller> Communication Settings, open the Communication Settings window,
select Ethernet-Direct connection, enter the IP address of PLC, click Ethernet
Communication Test, and the input box will prompt the test is successful.

Fig97. PLC EIP-E thernet Connect and perform the communication test
Note: If the PLC is connected to the BC50 via a switch, the Ethernet-Hub connection

should be selected.

12. Click the online icon first, then select the controller> transfer> transfer to the controller, then
completed the tested configuration is uploaded to the PLC device, seeFig 98。

Fig98. PLC EIP-Upload the configuration into the PLC device

13. Click the online icon, click the View> Monitor window, and open the Monitor (Engineering) 1,
egFig 99As shown, add a previously configured global monitoring variable.
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Fig99. PLC EIP-Adds a global variable in the monitoring window of the PLC device

 The BC50 code reader serves as an input to the PLC-EIP

 PLC-EIP supports a maximum input of 128 characters. Click the global input variable to
modify the display format of the corresponding byte, then the output of the reader will be
displayed in the input variable byte by byte, seeFig 100。

Fig100. PLC EIP-BC50 as an output

 The PLC triggers the BC50 code reader:

 The BC50 reader triggers in bit-trigger mode

1. Set the display format of OUT 8 [0] as: B inary.

2. Set the trigger bit for OUT 8 [0]: Write the binary value of the eight digits corresponding
to the trigger bit in the modification bar.refer toTable 22, If both 0 and 3 bit triggers are
allowed, the corresponding value of 0 and 3 bit is 0, then input 0000 1001. Similarly, if
only a 0-bit trigger is allowed, write to 0000 0001.

The X
position

7 6 5 4 3 2 1 0

price 0 0 0 0 1 0 0 1

Table22. PLC EIP-bit trigger example illustration

3. Write the above configuration to ensure that the above configuration takes effective.

 The BC50 reader is triggered in character trigger mode (seeFig 101）

1. Set the display format of OUT 8 [0] as ASCII.
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2. Set the trigger character for OUT 8 [0]: Write the trigger character in the modified value
bar (with the chapter12.1.1.5The trigger characters set in are consistent).in compliance
with T.

3. Write to all of the current configurations.

Fig101. PLC EIP-Character trigger

12.6 Modbus The configuration
The Modbus description given below is based on the Modbus P ool general software on the
network (for information about the Modbus slave BA (/ BC) 50 reader).
1. Open Modbus Pool, click the Connection> connect in the toolbar, open the Connection Setup

window, IP address input the IP address of BA (/ BC) 50 reader, keep the port number in
default (default value 502), click "OK".
Note: The ModubsPool shall be in the same network segment as the BA (/ BC) 50 reader.

Fig102. PLC Modbus-Modbus Connection configuration

2. Once the device is successfully connected, the default F=03, indicating the read save register.

Fig103The. PLC Modbus-Modbus was connected successfully
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3. Click the toolbar: Fire> New new window and enter Setup> Read / Write Definition. In the
outgoing configuration window, configure Function as 04 Read Input Registers (3x) to
indicate the read input register. Click OK to save the configuration.(Quantity: BA (/ BC) 50
supports up to 64 registers)

Fig104. PLC Modbus-Set BA (/ BC) 50 as the input register on the Modbus slave

 The BA (/ BC) 50 reader is triggered in character trigger mode (seeFig 105）

1. Double-click the first column in the first line of window 1 to open the Write Single Register
window and enter the ASCII code corresponding to the trigger character set in the section in
Value (referenceFig 106, If the ASCII code corresponding to T is 84), click "Send" to trigger
the device drawing decoding.

Fig105. PLC Modbus-Character trigger
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Fig106. PLC Modbus-ASCII mapping table

 The BA (/ BC) 50 reader is triggered in M odbus-bit trigger mode

1. In window 1, tick the box for Display> Binary.
2. in compliance withFig 107As shown, check the M odbus trigger bit set by the BA (/ BC) 50

reader in the outgoing window. Where the rightmost box represents the 0th digit, increasing
from right to left. If both 0-bit and 3-bit trigger are set, click OK after checking the chart and
clicking OK.

Fig107The. PLC Modbus-bit trigger



Tianjin Eco Automation Co., Ltd 0 ELCO-USG-01 78



Tianjin Eco Automation Co., Ltd 0 ELCO-USG-01 79

13 maintenance
Update the profile
Go to Task List> Update Configuration to Device (refFig 19), Select the configuration file to be
updated in the outgoing file browser window (extension:. config). If the update is successful, the
code reader will automatically restart.

Download the profile
Enter the Task list> Download Configuration to the computer to save the current configuration to
the local computer.

factory data reset
Go to Task List> Restore Factory Settings, and you are prompted to confirm that by selecting Yes
in the open dialog box, all environmental parameters will resume the factory default values,
including device configuration files and network configuration.

Update firmware
Go to Task List> Update firmware to device and select the firmware file to be updated in the
outgoing File browser window (extension:. package). Once the update is successful, the code
reader will automatically restart.

pay attention to

1. If you want to use the users own profile, download the current configuration locally before
updating the firmware, and update the saved profile to the device with the update profile function
after the firmware.
2. Update the configuration or update the firmware removes the original settings, please be
careful.

Download firmware
Enter the Task List> Download the firmware to your computer to save the current firmware to the
local computer.
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